Advertise here




Advertise here

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID

Error running Application 2.2.1 in simulator and iPhone after upgrade

dennisdeodennisdeo Posts: 24Registered Users
Hi,

I just upgraded to snow Leopard as well as xcode to 3.2. But i encounter a lot of problems after that.

At first, i open up the simulator, the simulator ask to choose for the sdk version from the pop up window. The simulator will just crash down if the SDK 2.2.1 or the earlier version is choose. Finally, it works fine after i choose the SDK3.0.

Next, i run my code with compiled with SDK2.2.1 in the simulator and i got the following error
dyld: Symbol not found: __CFStringGetUserDefaultEncoding
  Referenced from: /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
  Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator3.0.sdk/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
 in /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration

Is this means that only SDK3.0 code can be run in the simulator in snow leopard and i have to downgrade the OS back to Leopard in order to run the SDK2.2.1 or earlier version of the compilation code? Or is there any other solution to solve this issue?

Besides that, i also try to run the application in the iPhone. And this time, i got a compilation error as below :-
ProcessingProductPackaging /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS2.2.1.sdk/Entitlements.plist "/Users/admin/Desktop/razor v1.4/build/razor.build/Debug-iphoneos/razor.build/razor.xcent"
Command <com.apple.tools.product-pkg-utility> failed with exit code -1

I totally got no idea on what is going on. :mad: I tried to search in the google but couldn't find any solution for it. I got no issue on running this application at all before the upgrade. Does anyone know how to solve this problem??

Thanks
Post edited by dennisdeo on

Replies

  • falcon5280falcon5280 Posts: 361Registered Users
    edited June 2009
    There could be a couple issues. Your MAC OS needs to be 10.6 or higher and The Snow Leopard SDK is meant for 3.0 builds and may not work with all 2.X SDKS, since it does not include some of them. Here is the Apple langauige from the Snow leopard Read me file found in the SDK downloads section of the developer page. Hope this helps.

    Compatibility with Mac OS X Versions
    iPhone SDK requires an Intel-based Mac running Mac OS X Snow Leopard version
    10.6.0 or later.
    Xcode 3.2 is available as part of the Mac OS X Snow Leopard
    installation within the Optional Installs folder.
    *NOTE: this special install package is designed to work with the WWDC developer seed
    for Mac OS X 10.6 Snow Leopard. The iPhone OS 3.0 SDK included is similar to the
    final iPhone SDK for Mac OS X 10.5 Leopard, but as it targets a pre-release host
    operating system, these SDK tools should also be considered pre-release.
    Known Issues
    • This SDK-only install does not work on Mac OS X Leopard or Xcode 3.1.x
    • This SDK is designed to target 3.0 applications and does not include all 2.x SDKs
  • falcon5280falcon5280 Posts: 361Registered Users
    edited June 2009
    sorry, forgot to answer your question fully -- - yes, you probably need to go back to Leopard to run your 2.2.1 apps. But then you also need to go back to X3.1.3 because think 3.2 is snow leaopard only.
Sign In or Register to comment.