Advertise here




Advertise here

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Disabling the UIWebView "tap and hold" Popup

SenseiSensei Posts: 4New Users
edited December 2010 in iOS SDK Development
In iPhone OS 3.0 a feature has been added to Safari and UIWebView components. When you tap and hold on a link for a second an action sheet pops up from the bottom of the screen giving you the option to open the link, copy the URL or cancel the operation.

I'm using a UIWebView to render rich text together with a couple of controls and this functionality doesn't really fit well there.

Is anyone aware of a way to disable this for the entire UIWebView, or perhaps for individual links using some kind of CSS attribute?

Thanks in advance!
Post edited by Sensei on
·

Replies

  • johnnyutahjohnnyutah Posts: 8New Users
    edited July 2009
    Sensei wrote: »
    In iPhone OS 3.0 a feature has been added to Safari and UIWebView components. When you tap and hold on a link for a second an action sheet pops up from the bottom of the screen giving you the option to open the link, copy the URL or cancel the operation.

    I'm using a UIWebView to render rich text together with a couple of controls and this functionality doesn't really fit well there.

    Is anyone aware of a way to disable this for the entire UIWebView, or perhaps for individual links using some kind of CSS attribute?

    Thanks in advance!

    bump! how do we fix this. it's costing me a fortune!
    ·
  • kilobytedumpkilobytedump Posts: 195Registered Users
    edited January 2010
    Any movement on this guys?
    ·
  • kilobytedumpkilobytedump Posts: 195Registered Users
    edited January 2010
    Any movement on this guys?

    Actually here's the answer. It might help someone else :)

    Use CSS

    * {
    -webkit-touch-callout:none;
    }
    ·
  • Pedro ValentiniPedro Valentini Posts: 34Registered Users
    edited September 2010
    Actually here's the answer. It might help someone else :)

    Use CSS

    * {
    -webkit-touch-callout:none;
    }


    Thank you, it work.

    I don't know how you found it.. it is a very specific property...
    CSS Property : -webkit-touch-callout
    <a href="http://www.tecnalta.net" target="_blank">tecnalta.net</a>
    ·
  • jarekjarek Posts: 1New Users
    edited December 2010
    Unfortunately this doesn't work for iPad (4.2). Does anybody know the answer how this feature can be disabled on the iPad platform ?

    Thanks in advance,

    Jarek
    ·
Sign In or Register to comment.