Advertise here




Advertise here

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Application failed codesign verification

derek13derek13 Posts: 16Registered Users
edited March 2011 in iPhone SDK Development
I am up to a point where I am ready to submit my application to the iTunes store.

When I try uploading my app with the ApplicationLoader, I keep on getting the error message "Application failed codesign verification".

I followed Apple's instructions to use the distribution signing profile and etc. and also went back step by step again created another singing profile to see if it would work, but no luck :(

Did anyone experience this before or have any ideas that may solve this issue?

Thanks in advance!
Post edited by derek13 on

Replies

  • refresherefreshe SF, California | Melbourne, AustraliaPosts: 365Registered Users @ @
    edited August 2008
    make sure you have created Entitlements.plist in the root of the project, with one bool value "get-task-allow" set to false.

    then you have to go into the build info window and set the Code Sign Entitlements to Entitlements.plist


    that's what fixed it when i had that problem. my outdated guide didn't have it. took me a while to get that answer from someone :eek:
  • danzaphdanzaph Posts: 91Registered Users
    edited August 2008
    It sounds like the Bundle identifier is bad. Eithger it does not match your Provisioning Profile or the app unique portion has an illegal character in it. If you use a Bundle identifier like com.yours.${PRODUCT_NAME} and the app name has an unallowable character in it, like a space then it wont work. Best to use a Bundle identifier like com.yours.myAppName. The com.yours needs to match your Provisioning Profile like com.yours.*.
  • benwulfbenwulf Posts: 8New Users
    edited August 2008
    I had the same problem, here was the cause:
    at the project level you want to set your code signing identity, BUT LEAVE THE PROVISIONING PROFILE TO DEFAULT.
    Then at the target level you have to set both the code signing identity and the provisioning profile.

    If you fail to do that the package will be signed but not interpreted correctly by itunes connect.
    blog post where I found the fix

    Benwulf
  • MattCairnsMattCairns Posts: 103Registered Users @ @
    edited August 2008
    benwulf wrote: »
    I had the same problem, here was the cause:
    at the project level you want to set your code signing identity, BUT LEAVE THE PROVISIONING PROFILE TO DEFAULT.
    Then at the target level you have to set both the code signing identity and the provisioning profile.

    If you fail to do that the package will be signed but not interpreted correctly by itunes connect.
    blog post where I found the fix

    Benwulf

    This worked for me but maybe apple should remove that from the instructions because they tell you to do that lol.
  • benwulfbenwulf Posts: 8New Users
    edited August 2008
    MattCairns wrote: »
    This worked for me but maybe apple should remove that from the instructions because they tell you to do that lol.

    I agree, that is what step 4.6 tells you to do
  • RS8aRS8a Posts: 2New Users
    edited August 2008
    danzaph wrote: »
    It sounds like the Bundle identifier is bad. Eithger it does not match your Provisioning Profile or the app unique portion has an illegal character in it. If you use a Bundle identifier like com.yours.${PRODUCT_NAME} and the app name has an unallowable character in it, like a space then it wont work. Best to use a Bundle identifier like com.yours.myAppName. The com.yours needs to match your Provisioning Profile like com.yours.*.
    where I look if the Provisioning Profile and com.yours.${PRODUCT_NAME} are the same.


    Sorry my bad english but I don't know so much

    Pleas contact me in roberto.sandoval@ebsolutions.ws
  • Sunny DaySunny Day Posts: 142Registered Users
    edited May 2009
    Whats the end answer on this.

    I uploaded just fine with a small app on the itunes connect web page uploaded, but Im trying to upload a new app with the ApplicationLoader, but am getting the "Application failed codesign verification".

    I am unsure what I am supoosed to be doing different.
    I hear you saying.
    at the project level you want to set your code signing identity, BUT LEAVE THE PROVISIONING PROFILE TO DEFAULT.
    Then at the target level you have to set both the code signing identity and the provisioning profile.

    This has got my head spinning here. The only way I know of setting profiles is through the target file and then info. I am not sure what you are doing when you say project level you want to set your code signing identity.

    Then you say
    Then at the target level you have to set both the code signing identity and the provisioning profile.
    Thats what we do normally dont we, under build/codesigning we add provision profile and then properties identifier.

    What am I missing here please.
  • danzaphdanzaph Posts: 91Registered Users
    edited May 2009
    Sunny Day wrote: »
    Whats the end answer on this.

    The only way I know of setting profiles is through the target file and then info. I am not sure what you are doing when you say project level you want to set your code signing identity.

    What am I missing here please.

    If you double click the project icon, the very top left icon in the Xcode window you get the ability to set project wide settings.
  • Sunny DaySunny Day Posts: 142Registered Users
    edited May 2009
    Do you mean fig 1
    or Fig 2
    we can open fig 2, go to fig 3
    that opens showing bottom image.
    by default its set to fig 4.
    but when I sign apps I go target, info, then I go to fig 5 when i do normal signing for apps. Thats what the apple tutorials say to do.
    signtheapps.jpg
  • danzaphdanzaph Posts: 91Registered Users
    edited May 2009
    Remove all code signing from the project level (1), put it only in the target (2). It looks like you have the code signing in the project.
    untitled.png
    1 x 1 - 10K
    untitled.png 10.5K
  • Sunny DaySunny Day Posts: 142Registered Users
    edited May 2009
    clicking your thumbnail doesnt work

    it gives this
    You are not logged in or you do not have permission to access this page. This could be due to one of several reasons:

    1. You are not logged in. Fill in the form at the bottom of this page and try again.
    2. You may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
    3. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

    even though one is logged in, or logs in again
    Id like to see the image as a picture paints a thousand words.

    How I do this is just to go target, info, then fill in the details
    in the shot you see me open fig 2 and project and edit project settings, I thought you are saying do something with that, I dont normally touch it at all.
    Perhaps you are saying go to the project, and where I have fig 4, put dont code sign,
    then do what the apple tuts say normally, and you go to target info, and add the code signing.

    Is this what you are saying?
    Id try imageshack for your image, I think unless posters here are at a certian posting level, they dont get to see images that are hosted through the forums servers, as it gives me an error.

    I think it would help if this thread points the way, it comes up high in search engines and it has a lot of views, I think a lot of people have this problem.
  • danzaphdanzaph Posts: 91Registered Users
    edited May 2009
    Sunny Day wrote: »
    clicking your thumbnail doesnt work

    Image upload does not work for me, go to this link:
    http://zaph.com/target.png
    If you haven't figured out that there are two places to make settings go to the Apple Xcode docs: iphone_developer_program_user_guide__standard_program_v2.4.
    target.gif
    1 x 1 - 13K
  • Sunny DaySunny Day Posts: 142Registered Users
    edited May 2009
    Didnt Work, perhaps I miss something

    in your number 1 I went
    to my fig 2 then 3, then put in dont code sign.

    then in target and then code signing, I put my fig 5, as I sign all apps with fig 5.

    I then used application loader, and it didnt work, does fix it, perhaps I miss a step or I should of vioded something else, I dont now.

    Anything I missed here? More steps?
  • danzaphdanzaph Posts: 91Registered Users
    edited May 2009
    Sunny Day wrote: »
    I then used application loader, and it didnt work

    I never use the standalone uploader, just the web page.

    Best advice: Follow the instructions in the Apple doc I referenced. Match _every_ screenshot _exactly_. This includes a clean build and quit/restart.

    Perform the code signing checks outlined in the doc.
  • Sunny DaySunny Day Posts: 142Registered Users
    edited May 2009
    I never use the standalone uploader, just the web page.

    Then we are back at stage 1 then, the whole thread is from the OP

    When I try uploading my app with the ApplicationLoader, I keep on getting the error message "Application failed codesign verification".

    So everything we just discused, the screenshots, thats all a waste of time, I stated, it works when I use the web page, this thread is about the ApplicationLoader
  • blueyoblueyo Posts: 1New Users
    edited April 2010
    It tooks me days - but make sure you use the Distribution Provisioning - it was usefull to follow this advices: Sign in with your Apple ID - Apple Developer
  • sdkgianfrysdkgianfry Posts: 2New Users
    edited June 2010
    Apple documentation says you need to create Entitlements.plist only when submitting an App for AD HOC DISTRIBUTION

    Entitlements.plist is not necessary for AppStore


    refreshe wrote: »
    make sure you have created Entitlements.plist in the root of the project, with one bool value "get-task-allow" set to false.

    then you have to go into the build info window and set the Code Sign Entitlements to Entitlements.plist


    that's what fixed it when i had that problem. my outdated guide didn't have it. took me a while to get that answer from someone :eek:
  • sdkgianfrysdkgianfry Posts: 2New Users
    edited June 2010
    I'm experiencing this error...:
    Application failed codesign verification. The signature was invalid, or it was not signed with an Apple subsission certificate (-19011)"


    In my keychain everything seems alright, I got all the keys linked with certificates
    I got also the WorldWide...Certificate


    I tried with a general App Id like this generatedcode.*
    and with and explicit App Id like this generatedcode.com.myname.appname
    and changed the profile


    In Xcode organizer I have both Development and Distribution profiles correctly installed

    but when I build all my apps, there's no CODE SIGNING...
    and in Build Results I find this:
    Application failed codesign verification. The signature was invalid, or it was not signed with an Apple subsission certificate (-19011)"

    I sent a mail to Apple support with no useful answer

    can anybody help ?
    Thanks in advance



    sdkgianfry wrote: »
    Apple documentation says you need to create Entitlements.plist only when submitting an App for AD HOC DISTRIBUTION

    Entitlements.plist is not necessary for AppStore
  • mavster07mavster07 Posts: 9New Users
    edited July 2010
    refreshe wrote: »
    make sure you have created Entitlements.plist in the root of the project, with one bool value "get-task-allow" set to false.

    then you have to go into the build info window and set the Code Sign Entitlements to Entitlements.plist


    that's what fixed it when i had that problem. my outdated guide didn't have it. took me a while to get that answer from someone :eek:

    Hi

    A bit confused on the entitlements.plist file. Do you have a snapshot or contents of the file as to what it contains ?

    Mine contains the following (not sure if its correct or has too much info - i generated the default and had to add in get-task-allow and left it unchecked, which is FALSE):

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <!--- Required entitlements (in most cases shouldn't be changed) --->
    <key>application-identifier</key>
    <string>$(AppIdentifierPrefix)$(CFBundleIdentifier)</string>
    <key>keychain-access-groups</key>
    <array>
    <string>$(AppIdentifierPrefix)$(CFBundleIdentifier)</string>
    </array>

    <!--- Custom entitlements below --->


    </dict>
    </plist>
  • alexshemeshalexshemesh Posts: 1New Users
    edited August 2010
    I had this error too.
    When it comes to bureaucracy there is really no one like Apple.Every time i had to submit my application it takes 2 days of work no matter what i do or how close i follow Apple instructions.
    Anyway here is some tips.
    1.When you build your project XCode gives you warnings , make sure you clear as much warnings that mention plist file or Build signing.
    In my case it gave me some weird waring about enabling Validate Build product. in Target into page.
    2.Clear all settings about Code Signing and Entitlemens in Projects Info.
    3.Clear Code Signing Entitlements line in Target Info page.
    4.Set Code Signing Identity to Automatic profile selector for Distribution
    5.My biggest mistake was that i tried to modify wrong plist file, check out that you have only one plist file in your project and delete all others plist files.
    6. Pray to your personal God as often as you can and ask him to make it work, because in my experience this is only thing that really helps to overcome the problems with application submission to App Store.
  • blacknyellow11blacknyellow11 Posts: 2New Users
    edited September 2010
    Im having this same problem and i've tried everything!!!!!! its driving me crazy any help would be greatly appreciated i have no more ideas on what to try
  • bniubniu Posts: 7New Users
    edited December 2010
    Sunny Day wrote: »
    Do you mean fig 1
    or Fig 2
    we can open fig 2, go to fig 3
    that opens showing bottom image.
    by default its set to fig 4.
    but when I sign apps I go target, info, then I go to fig 5 when i do normal signing for apps. Thats what the apple tutorials say to do.
    signtheapps.jpg

    THANK YOU!!! YOU SOLVED MY ISSUE!!! :D Your pictures are worth 10K words!
  • birdkkbirdkk Posts: 2New Users
    edited December 2010
    Create and download your iOS Distribution Provisioning Profile for App Store Distribution :D

    https://developer.apple.com/ios/manage/distribution/index.action
  • dnaapplabdnaapplab Posts: 6New Users
    edited March 2011
    I solved the problem!! my case was i build using simulator rather than the actual devices. :D i wasted my own time!!!
Sign In or Register to comment.