Advertise here




Advertise here

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

The same "a signed resource has been added, modified or deleted" error on XCode 3.2.2

clouetteclouette Posts: 7New Users
edited February 2010 in iPhone SDK Development
While attempting to debug a build in XCode 3.2.2 on an iPhone device, I receive the message "A signed resource has been added, modified, or deleted.".

I can clean, rebuild, then install with no error, but if I try to install without cleaning the error shows.

Anyone have an idea as to what might be causing this?

I am still using the 3.0 and 2.2 SDK to build, not 3.2
Post edited by clouette on
· ·

Replies

  • SamGraySamGray Posts: 4New Users
    edited January 2010
    I'm having this same problem. From what I've read, from various sources, it's a problem with Xcode 3.2.2. Right now I'm trying to find a download for the old version of Xcode I was using before I updated to 3.2.2. I'm going to reinstall that version and see if it still gives me the message.

    The 3.2.2 version seems VERY bugged up right now, sadly.
    · ·
  • fxshotfxshot Posts: 75Registered Users
    edited January 2010
    I am having the same issue with one of my apps. I have found that if I delete it off the iPhone it will install fine. Hmmm. Def since XCode 3.2.2

    -mark
    Check out my app 'Dress Up Studio' on the iTunes Store -<br />
    <a href="http://itunes.apple.com/us/app/dress-up-studio/id359728350?mt=8" target="_blank">http://itunes.apple.com/us/app/dress...359728350?mt=8</a>;
    · ·
  • JasonRJasonR San Diego, CAPosts: 1,587Registered Users @ @ @ @
    edited January 2010
    Cleaning before building has been fixing this for me so far. But I hope they patch this soon.
    My development blog: <a href="http://jrinn.com" target="_blank">http://jrinn.com</a>;
    · ·
  • ingcontiingconti Posts: 1New Users
    edited January 2010
    clouette wrote: »
    While attempting to debug a build in XCode 3.2.2 on an iPhone device, I receive the message "A signed resource has been added, modified, or deleted.".

    I can clean, rebuild, then install with no error, but if I try to install without cleaning the error shows.

    Anyone have an idea as to what might be causing this?

    I am still using the 3.0 and 2.2 SDK to build, not 3.2


    it's a bug of 3.2.2.

    workarounds:
    1) clean will fix, but TOO invasive and you loose too much time
    2) simply delete build folder... manually OR via a script.
    3) delete "Debug-iphoneos" folder only..
    · ·
  • SamGraySamGray Posts: 4New Users
    edited January 2010
    I just switched back to Xcode 3.2.1 until Apple decides to fix this problem.
    · ·
  • _Mac_Mac Posts: 148Registered Users
    edited February 2010
    Same issue here. Also "Def since XCode 3.2.2"...

    Thanks for the tip of just deleting the app on the iPhone and then reinstall it again - that works fine for now.

    I guess Apple will be out with an patch soon for this.
    -- Happy Coding <img src="http://www.iphonedevsdk.com/forum/images/smilies/smile.gif" border="0" alt="" title="Smile" class="inlineimg" />
    · ·
  • ziocletoziocleto Posts: 1,107Registered Users @ @ @ @
    edited February 2010
    _Mac wrote: »
    Same issue here. Also "Def since XCode 3.2.2"...

    Thanks for the tip of just deleting the app on the iPhone and then reinstall it again - that works fine for now.

    I guess Apple will be out with an patch soon for this.

    Yes they patched it yesterday (9th Feb) with the 3.2 beta 2.
    <a href="http://itunes.apple.com/us/app/id443802549?mt=8" target="_blank">Paper Camera</a><br />
    · ·
Sign In or Register to comment.