Advertise here




Advertise here

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Start simulator in the background

deluded12gadeluded12ga Posts: 1New Users Noob
As the title says. I am looking for a way to get the iOS simulator to not start in the foreground. A little background on why, this is for testing. I have a selenium grid set up and using appium to test our app. The nodes are set up on tv's around the office that have mini's connected to them. The mini's have a chrome browser open in full screen presentation mode. So when the tests kick off and the simulator starts, it slides over to a new workspace and shows the simulator. That is what I do NOT want. I want the full screen chrome browser to stay on the screen.

I have tried a couple things already.

1. In system prefs -> Mission Control -> Uncheck "When switching to an application, switch to a Space with open windows for the application" - did not work
2. Ran this command "defaults write com.apple.dock workspaces-auto-swoosh -bool NO && killall Dock" - Did not work
3. Uninstalled it with "defaults delete com.apple.dock workspaces-auto-swoosh" - did not work
4. Added the simulator plist file to run in background similar to http://www.cnet.com/news/keep-applications-from-stealing-focus-when-opening-in-os-x/
but then get an simulator error about being on an authenticated disk :(

Any other thoughts out there that can accomplish this?

Replies

  • dev666999dev666999 Posts: 3,621New Users @ @ @ @ @
    There may be a way to set the screen coordinates, so that the simulator opens offscreen.

    I've done that in Windows. Never done it in OS X.

    Or...

    You can open a blank simulator, one that is open but not currently testing, and keep it behind your browser, until needed. Xcode has a button for that.
Sign In or Register to comment.